Intel acknowledges that there is a problem with Apple software and their RAID drivers in Vista

I finally contacted [MS] support center about iTunes/Vista/Intel RAID situation (so far I managed to contact only Intel technical support - they said that this isn't a problem in their drivers). Rok, the [MS] support guy, listened to me and after a couple of hours he found this article on Intel's website - a very recent modification of article I guess. Here is an excerpt of interest:

2294301, Timeouts, degraded RAID volumes when playing/transcoding video files in Apple iTunes* and QuickTime* software, Windows Vista

This is hardly surprising after all. The breaktrough is that they acknowledge that there is a problem with iTunes and QuickTime - the same problem we figured a while ago. Intel could see the problem a while ago, too, if they'd looked into the problem.  But they didn't - instead they buried their head in the sand, at least publicly.

The bottom line is that one of the parties involved acknowledged the problem and I suppose it will fix it in near future. Yes, there is a light at the end of the tunnel for us...

UPDATE 17.5.: After a reader posted a comment that there are new drivers version 7.5 I went checking Gigabyte web site and yes, there they are ("original" Intel drivers, not tied to Gigabyte mobos) and so are included release notes - it is clearly stated that they've fixed problems with Apple software. If you trust them, of course (a month ago or so, the technical support guy claimed that this problem doesn't have anything to do with their drivers). The same reader is reporting that the problem is actually gone with these latest drivers. A warning here is in place: Although it is not stated on Gigabyte web site, these 7.5.0.1017 SATA RAID drives are production candidate quality (aka RC version if you are a developer) and not final fully tested without errors (just with known issues). I think I'll wait a bit more, at least until final version is released and more positive reports will appear on the Internet. But if you dare install new drivers and test iTunes, please, don't hesitate to report the outcome (if your computer still boots :-P).

Comments (3) -

  • Drell

    5/22/2007 9:15:09 PM | Reply

    What are the dates on those drivers?

    I must be an idiot, cause I can't find the release notes for them.  MY mobo is an INTEL and if it is the 7.5.1017 drivers from the Intel site(they were released on Intel site on 3/30/2007) I think I still had some problems with them.

    I just now deleted the IASTOR parameter though, so maybe that will work?  

    AAHHH why not.. lets try it and see.

  • Drell

    5/22/2007 9:18:47 PM | Reply

    Duh, had to unzip the files first.  The release notes on Intel's website weren't actually these release notes.  It was just a crapola txt file with install instructions.  

  • Drell

    5/23/2007 10:24:18 AM | Reply

    Okay I tried it.  Had Itunes up and running all day.. still quirks... but no PC crashes.  I think Itunes crashed itself a few times but it looks like its usable.

    No Raid problems so far...  

Loading